Bij laatste versie toch de melding: "Your phpBB installation is not up to date."

Binnen het adminpanel van phpBB verschijnt de melding "Your phpBB installation is not up to date." in een rode balk. Dit wordt veroorzaakt doordat de tekst welke ontvangen wordt vanaf de server van phpBB niet in een goed formaat aankomt.

 

Dit is op te lossen door enkele regels aan te passen binnen de code van phpBB.

Zoek het bestand functions_admin.php op in de map includes en open deze in een tekstverwerker (bijvoorbeeld in de filemanager of via FTP). Zoek daarin de functie "obtain_latest_version_info" op en vervang de volgende twee regels:


$info= get_remote_file('version.phpbb.com','/phpbb',
((defined('PHPBB_QA'))?'30x_qa.txt':'30x.txt'),$errstr,$errno);


Met dit stukje code:


$curl=curl_init();
curl_setopt_array($curl,array(
CURLOPT_RETURNTRANSFER=>1,
CURLOPT_URL=>'http://version.phpbb.com/phpbb/'.((defined('PHPBB_QA'))?'30x_qa.txt':'30x.txt')
));

$resp=curl_exec($curl);
$info=$resp;

curl_close($curl);

Sla het bestand op en laat de admin opnieuw in. Hiermee zal het probleem verholpen zijn en dus de melding niet meer weergegeven worden.

  • 1 gebruikers vonden dit artikel nuttig
Was dit antwoord nuttig?

Gerelateerde artikelen

phpBB installeren

Hierbij een stappenplan om phpBB te installeren. Stap 1Download het pakket van de volgende link...